Mila Care Squad - Some users may experience temporary disconnects with their Milas. – Incident details

Some users may experience temporary disconnects with their Milas.

Resolved
Operational
Started almost 2 years agoLasted 13 days

Affected

🤝Device Pairing

Operational from 1:31 AM to 1:31 AM

📡Device Connection

Operational from 1:31 AM to 1:31 AM

Updates
  • Resolved
    Resolved

    Our team has been monitoring this for the last few days, and this issue has now been resolved. Thank you for your patience!

  • Monitoring
    Monitoring

    We've made optimizations to our backend services to stabilize connectivity for the users who may be experiencing connection drops. We are closely monitoring this and thank you for your patience.

  • Identified
    Identified

    Quick update from the Mila mothership: while we’ve addressed the majority of connection issues, we’re still continuing to see some instances where Milas may briefly disconnect, causing them to briefly appear offline in your app and failing to display your outdoor AQI on your Mila itself. You may notice this most when you first pair a Mila; please allow some time for your Mila to show up online (it’ll automatically reconnect!).

    While our engineering team is still working to fully address this issue, we’ve been able to trace it back to some of the upgrades we made over the weekend as part of our scheduled backend updates. We apologize for any inconvenience and please know that your Mila sensors are continuing to work hard to your indoor home health stats in the background.

  • Investigating
    Investigating

    We're currently investigating intermittent backend issues that might cause some units to temporarily disconnect, making them appear offline. Your Milas should come back online automatically. In very rare cases, some users may experience a short lapse in sensor readings. Apologies for any inconvenience, and we'll be back with an update as soon as we have more information.