Maintenance scheduled for Friday, Nov. 24, at 9PM PT

Completed
Scheduled for November 25, 2023 at 5:00 AM – 6:38 AM

Affects

🤝Device Pairing
📡Device Connection
🏠Indoor AQI Services
Updates
  • Completed
    November 25, 2023 at 6:38 AM
    Completed
    November 25, 2023 at 6:38 AM

    Maintenance has completed successfully.

  • In progress
    November 25, 2023 at 5:25 AM
    In progress
    November 25, 2023 at 5:25 AM

    Maintenance is in progress.

  • Planned
    November 25, 2023 at 5:00 AM
    Planned
    November 25, 2023 at 5:00 AM

    Hi all 👋 Jeremy here from the Mila Cares Squad — late tomorrow, Friday Nov. 24th, we've planned maintenance beginning from 21:00 PST (9pm), which we expect will last for 2 hours.

    During this time, communications between your Milas and the Mothership may be intermittent. Service will resume automatically after maintenance is complete.

    Thank you for your patience and understanding as we work to maintain the stability of our services.

    Take care and breathe easy!