Users may experience a loss in device connectivity

Resolved
Partial outage
Started over 1 year ago Lasted 27 minutes

Affected

📡Device Connection
Updates
  • Resolved
    Resolved

    We have identified and resolved the issue -- all Milas should now be back to their regularly scheduled programming.

  • Investigating
    Investigating

    We're currently investigating a connectivity issue where some units may report a lag in connection. In the meantime, you can continue to monitor and adjust your Milas using the on-display controls. If you have Child Lock on and need to reset it, please turn your Mila off/on. We'll be back with an update as soon as we have one.