Users may experience a loss in device connectivity

Resolved
Partial outage
Started about 1 year ago Lasted about 1 hour

Affected

🤝Device Pairing
📡Device Connection
Updates
  • Resolved
    Resolved

    We've resolved this issue and all Milas should now be back online.

  • Investigating
    Investigating

    We're currently investigating a connectivity issue where some units may report a loss in connection. In the meantime, you can continue to monitor and adjust your Milas using the on-display controls. If you have Child Lock on and need to reset it, please turn your Mila off/on. We'll be back with an update as soon as we have one.