We are investigating above-average load on our servers

Resolved
Degraded performance
Started about 1 year ago Lasted about 2 hours

Affected

🤝Device Pairing
📡Device Connection
🏠Indoor AQI Services
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We have implemented changes and are currently monitoring the results.

  • Investigating
    Investigating

    Our team has noticed above-average load against our services and we are investigating.