Show current status

[ResolvedNewly paired Milas may take ~15mins to show up online

Started on August 16, 2020 at 6:47 PMResolved after 8 days

Affected

📡Device Connection
  • Identified
    August 16, 2020 at 6:47 PM  –  

    We are continuing to upgrade our systems to handle the rush of new Milas onboarding each day.

  • Resolved
    August 25, 2020 at 5:42 AM  –  

    We just resolved the issue!