Show current status

[ResolvedThe outdoor air quality service is down for some users

Started on August 24, 2020 at 4:57 PMResolved after about 6 hours

Affected

😷Outdoor AQI Services
  • Identified
    August 24, 2020 at 4:57 PM  –  

    We are continuing to work on a fix for this incident.

  • Resolved
    August 24, 2020 at 11:17 PM  –  

    We just resolved the issue!