Completed
Server maintenance scheduled for Dec. 27th from 21:00 PDT.

Status
Resolved after about 3 hours
Started
December 28, 2023 at 5:00 AM
Completed
December 28, 2023 at 8:00 AM
Affects
🔑Account Creation & Login
🏠Indoor AQI Services
😷Outdoor AQI Services
  • Completed
    December 28, 2023 at 8:00 AM
    Completed
    December 28, 2023 at 8:00 AM

    Maintenance has completed successfully

  • In progress
    December 28, 2023 at 5:00 AM
    In progress
    December 28, 2023 at 5:00 AM

    Maintenance is now in progress

  • Planned
    December 28, 2023 at 5:00 AM
    Planned
    December 28, 2023 at 5:00 AM

    Hi all 👋 Jeremy here from the Mila Cares Squad — late tonight, Wednesday Dec. 27th, we've planned maintenance beginning from 21:00 PDT (9pm), which we expect will last for up to 3 hours.

    During this time, communications between your mobile apps for iOS, Android, and Smart Home devices will be intermittent or unavailable.
    You may have difficulties logging in or accessing data remotely while we upgrade our services.
    Service will resume automatically after maintenance is complete.

    Thank you for your patience and understanding as we complete routine server upgrades for stability and security.

    Take care and breathe easy!