Completed
Server maintenance scheduled for tomorrow, Jan. 19th, at 1:00AM PT

Status
Resolved after about 2 hours
Started
January 19, 2024 at 9:00 AM
Completed
January 19, 2024 at 11:20 AM
Affects
🔑Account Creation & Login
🤝Device Pairing
📡Device Connection
🏠Indoor AQI Services
😷Outdoor AQI Services
  • Completed
    January 19, 2024 at 11:19 AM
    Completed
    January 19, 2024 at 11:19 AM

    Maintenance has been completed successfully and all services are back online.

    Breathe easy, and have a great weekend!

  • Update
    January 19, 2024 at 11:00 AM
    In progress
    January 19, 2024 at 11:00 AM

    Hi everyone, we're continuing to work through issues in the final phases of deployment.

    We've extended our maintenance further while we wrap-up issues with the final deployment & reconnection of your Milas.

  • Update
    January 19, 2024 at 9:58 AM
    In progress
    January 19, 2024 at 9:58 AM

    Hi all, maintenance is still in progress and will be extended for another hour.

    Thank you for your patience.

  • In progress
    January 19, 2024 at 9:00 AM
    In progress
    January 19, 2024 at 9:00 AM

    Maintenance is now in progress

  • Planned
    January 19, 2024 at 9:00 AM
    Planned
    January 19, 2024 at 9:00 AM

    Hi all 👋 Jeremy here from the Mila Cares Squad — early tomorrow, Friday Jan. 19th, we've planned maintenance beginning from 01:00 PST (1AM), which we expect will last for up to 1 hour.

    During this time, communications between your mobile apps for iOS, Android, and Smart Home devices will be intermittent or unavailable.
    You may have difficulties logging in or accessing data remotely while we upgrade our services.
    Service will resume automatically after maintenance is complete.
    Appliances may appear offline / disconnected during maintenance.

    Thank you for your patience and understanding as we complete routine server upgrades for stability and security.

    Take care and breathe easy!